| OID symbolic | OID numeric | Type | Access | Description |
| etsysRadiusAuthClientMIB | 1.3.6.1.4.1.5624.1.2.4 | | | The Enterasys Networks Proprietary MIB module for entities
implementing the client side of the Remote Access Dialin
User Service (RADIUS) authentication protocol (RFC2865).
This MIB provides read-write access to configuration objects
not provided in the standard RADIUS Authentication Client
MIB (RFC2618). |
| etsysRadiusAuthClientMIBObjects | 1.3.6.1.4.1.5624.1.2.4.1 | | | |
| I32 etsysRadiusAuthClientRetryTimeout | 1.3.6.1.4.1.5624.1.2.4.1.1 | Integer32 | read-write | The number of seconds to wait for a RADIUS Server to respond to
a request. Maintaining the value of this object across agent
reboots is REQUIRED. |
| I32 etsysRadiusAuthClientRetries | 1.3.6.1.4.1.5624.1.2.4.1.2 | Integer32 | read-write | The number of times to resend an authentication packet if a
RADIUS Server does not respond to a request. Maintaining the
value of this object across agent reboots is REQUIRED. |
| INT etsysRadiusAuthClientEnable | 1.3.6.1.4.1.5624.1.2.4.1.3 | INTEGER | read-write | Controls and indicates the operational state of the RADIUS
client functionality. Maintaining the value of this object
across agent reboots is REQUIRED. |
| INT etsysRadiusAuthClientAuthType | 1.3.6.1.4.1.5624.1.2.4.1.4 | INTEGER | read-write | This indicates which method is being used for
authentication.
mac(1) - indicates MAC address authentication
eapol(2) - indicates EAPOL authentication
This list of enumeration constants is subject to
change. This parameter value is maintained across
system reboots. |
| etsysRadiusAuthServerTable | 1.3.6.1.4.1.5624.1.2.4.1.5 | | not-accessible | A list of RADIUS servers that this client may attempt to use. |
| etsysRadiusAuthServerEntry | 1.3.6.1.4.1.5624.1.2.4.1.5.1 | | not-accessible | A RADIUS server that this client may attempt to use. |
| I32 etsysRadiusAuthServerIndex | 1.3.6.1.4.1.5624.1.2.4.1.5.1.1 | Integer32 | not-accessible | A number uniquely identifying each conceptual row in the
etsysRadiusAuthServerTable. This value also indicates the
relative priority of the servers. The initial authentication
attempt will be against the server with the lowest value of
etsysRadiusAuthServerIndex and any successive attempt will
be with the next higher value, and so on.
Maintaining the value of etsysRadiusAuthServerIndex for all
active(1) entries across agent reboots is REQUIRED. |
| IPt etsysRadiusAuthClientServerAddressType | 1.3.6.1.4.1.5624.1.2.4.1.5.1.2 | InetAddressType | read-create | This object specifies how etsysRadiusAuthClientServerAddress
is encoded. Support for all possible enumerations defined by
InetAddressType is NOT REQUIRED. |
| IP etsysRadiusAuthClientServerAddress | 1.3.6.1.4.1.5624.1.2.4.1.5.1.3 | InetAddress | read-create | The encoded unicast IP address or hostname of a RADIUS
server. RADIUS requests will be sent to this address.
If this address is a DNS hostname, then that hostname
SHOULD be resolved into an IP address each time an
authentication session is initialized. |
| I32 etsysRadiusAuthClientServerPortNumber | 1.3.6.1.4.1.5624.1.2.4.1.5.1.4 | Integer32 | read-create | The UDP port number (0-65535) the client will use
to send RADIUS requests to this server. |
| OCT etsysRadiusAuthClientServerSecret | 1.3.6.1.4.1.5624.1.2.4.1.5.1.5 | OCTET STRING | read-create | This object is the secret shared between the RADIUS
authentication server and the RADIUS client.
On a read operation this object MUST return a zero length
string.
Writing this object with a zero length string clears the
secret. |
| T/F etsysRadiusAuthClientServerSecretEntered | 1.3.6.1.4.1.5624.1.2.4.1.5.1.6 | TruthValue | read-only | true(1) - Indicates that etsysRadiusAuthClientServerSecret was
last set with some value other than the empty string.
false(2) - Indicates that etsysRadiusAuthClientServerSecret has
never been set, or was last set to the empty string. |
| I32 etsysRadiusAuthClientServerClearTime | 1.3.6.1.4.1.5624.1.2.4.1.5.1.7 | Integer32 | read-create | The number of seconds elapsed since the counters were last
cleared.
Writing the value zero will cause the servers counters to be
cleared and the clear time will be set to zero. Writing any
value other than zero will have no effect. |
| ROW etsysRadiusAuthClientServerStatus | 1.3.6.1.4.1.5624.1.2.4.1.5.1.8 | RowStatus | read-create | The row status of this conceptual row in the table.
active
- The server is available for performing RADIUS operations.
Other writable leaves in this row MUST NOT be modified
while the row is in the active state.
notInService
- The entry is fully configured but is not available for
performing RADIUS operations. Conceptual rows with this
status MAY be deleted at the discretion of the agent,
at which time it will be treated as if destroy(6) was SET
to this object.
notReady
- The entry exists in the agent, but is missing information
necessary in order to be available for use by the managed
device (i.e., one or more required columns in the
conceptual row have not been instantiated);
createAndGo
- Not possible.
createAndWait
- Creates a new instance of a conceptual row, but does not
make it available for use by the managed device.
destroy
- This will remove the conceptual row from the table and
make it unavailable for RADIUS client operations. This
MUST also cause any persistent data related to this row
to be removed from the system.
Maintaining active(1) entries across agent reboots is
REQUIRED. |
| INT etsysRadiusAuthClientServerRealmType | 1.3.6.1.4.1.5624.1.2.4.1.5.1.9 | INTEGER | read-create | This object allows a server to be restricted to providing
authentication services to certain classes of access methods.
any(1) - the server will be available to
authenticate users originating from
any of the access methods.
mgmtAccess(2) - the server will only be available for
authenticating users that have requested
management access via the console, telnet,
SSH, HTTP, etc.
networkAccess(3) - the server will only be available for
authenticating users that are attempting
to gain access to the network via 802.1X,
Port Web Authentication, MAC Authentication,
etc.
Non-default values for this object should be used when there is
a desire to have one set of servers used for authenticating
management access requests and a different set used for
authenticating network access requests. When this object has
the value of any(1) then the associated server will be in each
set. The precedence order defined by the relative value of the
etsysRadiusAuthServerIndex will be maintained within each set of
servers. |
| I32 etsysRadiusAuthClientServerTimeout | 1.3.6.1.4.1.5624.1.2.4.1.5.1.10 | Integer32 | read-create | The number of seconds to wait for a RADIUS Server to respond to
a request. A value of -1 indicates that the server timeout
specified by etsysRadiusAuthClientRetryTimeout should be used
for this server. Maintaining the value of this object across
agent reboots is REQUIRED. |
| I32 etsysRadiusAuthClientServerRetries | 1.3.6.1.4.1.5624.1.2.4.1.5.1.11 | Integer32 | read-create | The number of times to resend an authentication packet if a
RADIUS Server does not respond to a request. A value of -1
indicates that the server retries specified by
etsysRadiusAuthClientRetries should be used for this server.
Maintaining the value of this object across agent reboots is
REQUIRED. |
| INT etsysRadiusAuthClientAttrMgmtPassword | 1.3.6.1.4.1.5624.1.2.4.1.6 | INTEGER | read-write | This value indicates which method is being used to send
management access passwords to the RADIUS server.
standard(1) - Use the User-Password attribute at defined in
RFC2865
mschapv2(2) - Use the MS-CHAP2-Response attribute as defined
in RFC2548
This parameter value is maintained across system reboots. |
| etsysRadiusAuthClientMIBConformance | 1.3.6.1.4.1.5624.1.2.4.2 | | | |
| etsysRadiusAuthClientMIBCompliances | 1.3.6.1.4.1.5624.1.2.4.2.1 | | | |
| etsysRadiusClientMIBCompliance | 1.3.6.1.4.1.5624.1.2.4.2.1.1 | | | The compliance statement for authentication clients
implementing the RADIUS Authentication Client MIB. |
| etsysRadiusClientMIBComplianceV2 | 1.3.6.1.4.1.5624.1.2.4.2.1.2 | | | The compliance statement for authentication clients
implementing the RADIUS Authentication Client MIB. |
| etsysRadiusClientMIBComplianceV3 | 1.3.6.1.4.1.5624.1.2.4.2.1.3 | | | The compliance statement for authentication clients
implementing the RADIUS Authentication Client MIB. |
| etsysRadiusClientMIBComplianceV4 | 1.3.6.1.4.1.5624.1.2.4.2.1.4 | | | The compliance statement for authentication clients
implementing the RADIUS Authentication Client MIB. |
| etsysRadiusAuthClientMIBGroups | 1.3.6.1.4.1.5624.1.2.4.2.2 | | | |
| etsysRadiusAuthClientMIBGroup | 1.3.6.1.4.1.5624.1.2.4.2.2.1 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
This MIB provides read-write access to configuration objects
not provided in the standard RADIUS Authentication Client
MIB (RFC2618). |
| etsysRadiusAuthClientMIBGroupV2 | 1.3.6.1.4.1.5624.1.2.4.2.2.2 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
This MIB provides read-write access to configuration objects
not provided in the standard RADIUS Authentication Client
MIB (RFC2618). |
| etsysRadiusAuthClientMIBGroupV3 | 1.3.6.1.4.1.5624.1.2.4.2.2.3 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
This MIB provides read-write access to configuration objects
not provided in the standard RADIUS Authentication Client
MIB (RFC2618). |
| etsysRadiusAuthClientMIBGroupV4 | 1.3.6.1.4.1.5624.1.2.4.2.2.4 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
This MIB provides read-write access to configuration objects
not provided in the standard RADIUS Authentication Client
MIB (RFC2618). |