| OID symbolic | OID numeric | Type | Access | Description |
| sipServerMIB | 1.3.6.1.2.1.151 | | | Session Initiation Protocol (SIP) Server MIB module. SIP is an
application-layer signaling protocol for creating, modifying,
and terminating multimedia sessions with one or more
participants. These sessions include Internet multimedia
conferences and Internet telephone calls. SIP is defined in
RFC 3261 (June 2002).
This MIB is defined for the management of SIP Proxy, Redirect,
and Registrar Servers.
A Proxy Server acts as both a client and a server. It accepts
requests from other clients, either responding to them or
passing them on to other servers, possibly after modification.
A Redirect Server accepts requests from clients and returns
zero or more addresses to that client. Unlike a User Agent
Server, it does not accept calls.
A Registrar is a server that accepts REGISTER requests. A
Registrar is typically co-located with a Proxy or Redirect
Server.
Copyright (C) The IETF Trust (2007). This version of
this MIB module is part of RFC 4780; see the RFC itself for
full legal notices. |
| sipServerMIBObjects | 1.3.6.1.2.1.151.1 | | | |
| sipServerCfg | 1.3.6.1.2.1.151.1.1 | | | |
| sipServerCfgTable | 1.3.6.1.2.1.151.1.1.1 | | not-accessible | This table contains configuration objects applicable to SIP
Redirect and Proxy Servers. |
| sipServerCfgEntry | 1.3.6.1.2.1.151.1.1.1.1 | | not-accessible | A row of common configuration.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through
the common framework of the NETWORK-SERVICES-MIB (RFC 2788).
The same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| IPt sipServerCfgHostAddressType | 1.3.6.1.2.1.151.1.1.1.1.1 | InetAddressType | read-only | The type of Internet address by which the SIP server is
reachable. |
| IP sipServerCfgHostAddress | 1.3.6.1.2.1.151.1.1.1.1.2 | InetAddress | read-only | This is the host portion of a SIP URI that is assigned to the
SIP server. It MAY contain a fully qualified domain name or
an IP address. The length of the value will depend on the type
of address specified. The type of address given by this object
is controlled by sipServerCfgHostAddressType. |
| sipServerProxyCfg | 1.3.6.1.2.1.151.1.3 | | | |
| sipServerProxyCfgTable | 1.3.6.1.2.1.151.1.3.1 | | not-accessible | This table contains configuration objects applicable to SIP
Proxy Servers. |
| sipServerProxyCfgEntry | 1.3.6.1.2.1.151.1.3.1.1 | | not-accessible | A row of common proxy configuration.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through the
common framework of the NETWORK-SERVICES-MIB (RFC 2788). The
same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| INT sipServerCfgProxyStatefulness | 1.3.6.1.2.1.151.1.3.1.1.1 | INTEGER | read-only | This object reflects the default mode of operation for the
Proxy Server entity.
A stateless proxy is a logical entity that does not maintain
the client or server transaction state machines when it
processes requests. A stateless proxy forwards every request it
receives downstream and every response it receives upstream. If
the value of this object is stateless(1), the proxy defaults to
stateless operations.
A transaction stateful proxy, or simply a 'stateful proxy', is
a logical entity that maintains the client and server
transaction state machines during the processing of a request.
A (transaction) stateful proxy is not the same as a call
stateful proxy. If the value of this object is
transactionStateful(2), the proxy is stateful on a transaction
basis.
A call stateful proxy is a logical entity if it retains state
for a dialog from the initiating INVITE to the terminating BYE
request. A call stateful proxy is always transaction stateful,
but the converse is not necessarily true. If the value of this
object is callStateful(3), the proxy is call stateful. |
| T/F sipServerCfgProxyRecursion | 1.3.6.1.2.1.151.1.3.1.1.2 | TruthValue | read-only | This object reflects whether or not the Proxy performs a
recursive search on the Contacts provided in 3xx redirects.
If the value of this object is 'true', a recursive search is
performed. If the value is 'false', no search is performed,
and the 3xx response is sent upstream towards the source of
the request. |
| T/F sipServerCfgProxyRecordRoute | 1.3.6.1.2.1.151.1.3.1.1.3 | TruthValue | read-only | This object reflects whether or not the proxy adds itself to
the Record-Route header as a default action. This header is
used to list the proxies that insist on being in the signaling
path for subsequent requests related to the call leg.
If the value of this object is 'true', the proxy adds itself to
the end of the Record-Route header, creating the header if
required. If the value is 'false', the proxy does not add
itself to the Record-Route header. |
| BIT sipServerCfgProxyAuthMethod | 1.3.6.1.2.1.151.1.3.1.1.4 | Bits | read-only | This object reflects the authentication methods that MAY be
used to authenticate request originators.
bit 0 no authentication is performed
bit 1 TLS is used
bit 2 HTTP Digest is used. |
| STR sipServerCfgProxyAuthDefaultRealm | 1.3.6.1.2.1.151.1.3.1.1.5 | SnmpAdminString | read-only | This object reflects the default realm value used in
Proxy-Authenticate headers. Note that this MAY need to be
stored per user, in which case, this default value is ignored. |
| sipServerProxyStats | 1.3.6.1.2.1.151.1.4 | | | |
| sipServerProxyStatsTable | 1.3.6.1.2.1.151.1.4.1 | | not-accessible | This table contains the statistics objects applicable to all
SIP Proxy Servers in this system. |
| sipServerProxyStatsEntry | 1.3.6.1.2.1.151.1.4.1.1 | | not-accessible | A row of summary statistics.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through the
common framework of the NETWORK-SERVICES-MIB (RFC 2788). The
same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| C32 sipServerProxyStatProxyReqFailuresEx | 1.3.6.1.2.1.151.1.4.1.1.1 | Counter32 | read-only | This object contains the number of occurrences of unsupported
options being specified in received Proxy-Require headers.
Such occurrences result in a 420 Bad Extension status code
being returned.
Discontinuities in the value of this counter can occur at
re-initialization of the SIP entity or service. A Management
Station can detect discontinuities in this counter by
monitoring the sipServerProxyStatsDisconTime object in the same
row. |
| TIM sipServerProxyStatsDisconTime | 1.3.6.1.2.1.151.1.4.1.1.2 | TimeStamp | read-only | The value of the sysUpTime object when the counters for the server
statistics objects in this row last experienced a discontinuity. |
| sipServerRegCfg | 1.3.6.1.2.1.151.1.5 | | | |
| sipServerRegCfgTable | 1.3.6.1.2.1.151.1.5.1 | | not-accessible | This table contains configuration objects applicable to SIP
Registrars. |
| sipServerRegCfgEntry | 1.3.6.1.2.1.151.1.5.1.1 | | not-accessible | A row of common Registrar configuration.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through the
common framework of the NETWORK-SERVICES-MIB (RFC 2788). The
same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| U32 sipServerRegMaxContactExpiryDuration | 1.3.6.1.2.1.151.1.5.1.1.1 | Unsigned32 | read-only | This object reflects the maximum expiry that may be requested
by a User Agent for a particular Contact. User Agents can
specify expiry using either an Expiry header in a REGISTER
request, or using an Expires parameter in a Contact header in
a REGISTER request. If the value requested by the User Agent
is greater than the value of this object, then the contact
information is given the duration specified by this object, and
that duration is indicated to the User Agent in the response. |
| U32 sipServerRegMaxUsers | 1.3.6.1.2.1.151.1.5.1.1.2 | Unsigned32 | read-only | This object reflects the maximum number of users that the
Registrar supports. The current number of users is reflected
by sipServerRegCurrentUsers. |
| G32 sipServerRegCurrentUsers | 1.3.6.1.2.1.151.1.5.1.1.3 | Gauge32 | read-only | This object reflects the number of users currently registered
with the Registrar. |
| U32 sipServerRegDfltRegActiveInterval | 1.3.6.1.2.1.151.1.5.1.1.4 | Unsigned32 | read-only | This object reflects the default time interval the Registrar
considers registrations to be active. The value is used to
compute the Expires header in the REGISTER response. If a user
agent requests a time interval shorter than specified by this
object, the Registrar SHOULD honor that request. If a Contact
entry does not have an 'expires' parameter, the value of the
Expires header field is used instead. If a Contact entry has no
'expires' parameter and no Expires header field is present,
the value of this object is used as the default value. |
| sipServerRegUserTable | 1.3.6.1.2.1.151.1.5.2 | | not-accessible | This table contains information on all users registered to each
Registrar in this system. |
| sipServerRegUserEntry | 1.3.6.1.2.1.151.1.5.2.1 | | not-accessible | This entry contains information for a single user registered to
this Registrar.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through the
common framework of the NETWORK-SERVICES-MIB (RFC 2788). The
same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| U32 sipServerRegUserIndex | 1.3.6.1.2.1.151.1.5.2.1.1 | Unsigned32 | not-accessible | This object uniquely identifies a conceptual row in the table. |
| STR sipServerRegUserUri | 1.3.6.1.2.1.151.1.5.2.1.2 | SnmpAdminString | read-only | This object contains the user's address-of-record. It is the
main form by which the Registrar knows the user. The format is
typically 'user@domain'. It is contained in the To header for
all REGISTER requests. |
| C32 sipServerRegUserAuthenticationFailures | 1.3.6.1.2.1.151.1.5.2.1.3 | Counter32 | read-only | This object contains a count of the number of times the user
has failed authentication.
Discontinuities in the value of this counter can occur due to
successful user authentications and at re-initialization of
the SIP entity or service. A Management Station can detect
discontinuities in this counter by monitoring the
sipServerRegUserDisconTime object in the same row. |
| TIM sipServerRegUserDisconTime | 1.3.6.1.2.1.151.1.5.2.1.4 | TimeStamp | read-only | The value of the sysUpTime object when the counters for the
user registration statistics objects in this row last
experienced a discontinuity. |
| sipServerRegContactTable | 1.3.6.1.2.1.151.1.5.3 | | not-accessible | This table contains information on every location where a
registered user (specified by sipServerRegUserIndex) wishes to
be found (i.e., the user has provided contact information to
each SIP Registrar in this system). |
| sipServerRegContactEntry | 1.3.6.1.2.1.151.1.5.3.1 | | not-accessible | This entry contains information for a single Contact. Multiple
contacts may exist for a single user.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through the
common framework of the NETWORK-SERVICES-MIB (RFC 2788). The
same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| U32 sipServerRegContactIndex | 1.3.6.1.2.1.151.1.5.3.1.1 | Unsigned32 | not-accessible | Along with the sipServerRegUserIndex, this object uniquely
identifies a conceptual row in the table. |
| STR sipServerRegContactDisplayName | 1.3.6.1.2.1.151.1.5.3.1.2 | SnmpAdminString | read-only | This object contains the display name for the Contact. For
example, 'Santa at Home', or 'Santa on his Sled', corresponding
to contact URIs of sip:BigGuy@example.com or
sip:sclaus817@example.com, respectively. |
| STR sipServerRegContactURI | 1.3.6.1.2.1.151.1.5.3.1.3 | SnmpAdminString | read-only | This object contains either a SIP URI where the user can be
contacted. This URI is normally returned to a client from a
Redirect Server, or is used as the RequestURI in a SIP request
line for requests forwarded by a proxy. |
| TIM sipServerRegContactLastUpdated | 1.3.6.1.2.1.151.1.5.3.1.4 | TimeStamp | read-only | This object indicates the time when this contact information
was accepted. If the contact information is updated via a
subsequent REGISTER of the same information, this object is
also updated. |
| DAT sipServerRegContactExpiry | 1.3.6.1.2.1.151.1.5.3.1.5 | DateAndTime | read-only | This object contains the date and time when the contact
information will no longer be valid. Such times may be
specified by the user at registration (i.e., Expires header or
expiry parameter in the Contact information), or a system
default can be applied. |
| STR sipServerRegContactPreference | 1.3.6.1.2.1.151.1.5.3.1.6 | SnmpAdminString | read-only | This object indicates a relative preference for the particular
Contact header field value compared to other bindings for this
address-of-record. A registering user may provide this
preference as a 'qvalue' parameter in the Contact header.
The format of this item is a decimal number between 0 and 1
(for example 0.9). Higher values indicate locations preferred
by the user. |
| sipServerRegStats | 1.3.6.1.2.1.151.1.6 | | | |
| sipServerRegStatsTable | 1.3.6.1.2.1.151.1.6.1 | | not-accessible | This table contains the summary statistics objects applicable
to all SIP Registrars in this system. |
| sipServerRegStatsEntry | 1.3.6.1.2.1.151.1.6.1.1 | | not-accessible | A row of summary statistics.
Each row represents those objects for a particular SIP server
present in this system. applIndex is used to uniquely identify
these instances of SIP servers and correlate them through the
common framework of the NETWORK-SERVICES-MIB (RFC 2788). The
same value of applIndex used in the corresponding
SIP-COMMON-MIB is used here. |
| C32 sipServerRegStatsAcceptedRegs | 1.3.6.1.2.1.151.1.6.1.1.1 | Counter32 | read-only | This object contains a count of the number of REGISTER requests
that have been accepted (status code 200) by the Registrar.
This includes additions of new contact information, refreshing
contact information, as well as requests for deletion of
contact information.
Discontinuities in the value of this counter can occur at
re-initialization of the SIP entity or service. A Management
Station can detect discontinuities in this counter by
monitoring the sipServerRegStatsDisconTime object in the same
row. |
| C32 sipServerRegStatsRejectedRegs | 1.3.6.1.2.1.151.1.6.1.1.2 | Counter32 | read-only | This object contains a count of the number REGISTER requests
that have been rejected by the Registrar.
Discontinuities in the value of this counter can occur at
re-initialization of the SIP entity or service. A Management
Station can detect discontinuities in this counter by
monitoring the sipServerRegStatsDisconTime object in the same
row. |
| TIM sipServerRegStatsDisconTime | 1.3.6.1.2.1.151.1.6.1.1.3 | TimeStamp | read-only | The value of the sysUpTime object when the counters for the
registrar statistics objects in this row last experienced a
discontinuity. |
| sipServerMIBConformance | 1.3.6.1.2.1.151.2 | | | |
| sipServerMIBCompliances | 1.3.6.1.2.1.151.2.1 | | | |
| sipServerProxyServerCompliance | 1.3.6.1.2.1.151.2.1.1 | | | The compliance statement for SIP entities acting as Proxy
Servers. |
| sipRedirectServerCompliance | 1.3.6.1.2.1.151.2.1.2 | | | The compliance statement for SIP entities acting as Redirect
Servers. |
| sipServerRegistrarServerCompliance | 1.3.6.1.2.1.151.2.1.3 | | | The compliance statement for SIP entities acting as
Registrars. |
| sipServerMIBGroups | 1.3.6.1.2.1.151.2.2 | | | |
| sipServerConfigGroup | 1.3.6.1.2.1.151.2.2.1 | | | A collection of objects providing configuration common to SIP
Proxy and Redirect servers. |
| sipServerProxyConfigGroup | 1.3.6.1.2.1.151.2.2.2 | | | A collection of objects providing configuration for SIP Proxy
servers. |
| sipServerProxyStatsGroup | 1.3.6.1.2.1.151.2.2.3 | | | A collection of objects providing statistics for SIP Proxy
servers. |
| sipServerRegistrarConfigGroup | 1.3.6.1.2.1.151.2.2.4 | | | A collection of objects providing configuration for SIP
Registrars. |
| sipServerRegistrarStatsGroup | 1.3.6.1.2.1.151.2.2.5 | | | A collection of objects providing statistics for SIP
Registrars. |
| sipServerRegistrarUsersGroup | 1.3.6.1.2.1.151.2.2.6 | | | A collection of objects related to registered users. |