| OID symbolic | OID numeric | Type | Access | Description |
| etsysRadiusAcctClientMIB | 1.3.6.1.4.1.5624.1.2.27 | | | This MIB module defines a portion of the SNMP enterprise
MIBs under Enterasys Networks' enterprise OID pertaining to
the client side of the Remote Access Dialin User Service
(RADIUS) Accounting protocol (RFC2866).
This MIB provides read-write access to configuration objects
not provided in the standard RADIUS Accounting Client
MIB (RFC2620). However, the write capability must only
be supported for SNMPv3, or other SNMP versions with
adequately strong security.
Security concerns include Object ID verification, source
address verification and timeliness verification. |
| etsysRadiusAcctClientMIBObjects | 1.3.6.1.4.1.5624.1.2.27.1 | | | |
| INT etsysRadiusAcctClientEnable | 1.3.6.1.4.1.5624.1.2.27.1.1 | INTEGER | read-write | This object indicates whether or not RADIUS Accounting
is enabled or disabled. This parameter value is maintained
across system reboots. |
| I32 etsysRadiusAcctClientUpdateInterval | 1.3.6.1.4.1.5624.1.2.27.1.2 | Integer32 | read-write | This indicates how many seconds elapse between accounting
interim updates. This parameter value is maintained across
system reboots. A value of zero means no Interim Updates.
If the value is less than etsysRadiusAcctClientIntervalMinimum,
the etsysRadiusAcctClientIntervalMinimum value will be used
for the update interval time. If RADIUS Accounting is not
enabled, this object is ignored. Note that Accounting
Interim Updates are not issued by the RADIUS Accounting
Client, unless so requested by the RADIUS Server in an Access
Accept packet. |
| I32 etsysRadiusAcctClientIntervalMinimum | 1.3.6.1.4.1.5624.1.2.27.1.3 | Integer32 | read-write | This indicates the minimum value in seconds between
accounting interim updates supported by the managed
entity. This parameter value is maintained across
system reboots. If RADIUS Accounting is not enabled,
this object is ignored. |
| etsysRadiusAcctClientServerTable | 1.3.6.1.4.1.5624.1.2.27.1.4 | | not-accessible | The (conceptual) table listing the RADIUS Accounting
servers. |
| etsysRadiusAcctClientServerEntry | 1.3.6.1.4.1.5624.1.2.27.1.4.1 | | not-accessible | An entry (conceptual row) representing a RADIUS
Accounting server with which the client shares
a secret. If RADIUS Accounting is not enabled, this
table is ignored.
All created conceptual rows are non-volatile and as such
must be maintained upon restart of the agent. |
| I32 etsysRadiusAcctClientServerIndex | 1.3.6.1.4.1.5624.1.2.27.1.4.1.1 | Integer32 | not-accessible | A number uniquely identifying each conceptual row
in the etsysRadiusAcctClientServerTable.
In the event of an agent restart, the same value
of etsysRadiusAcctClientServerIndex must be used to
identify each conceptual row in
etsysRadiusAcctClientServerTable as was used prior
to the restart. |
| IPt etsysRadiusAcctClientServerAddressType | 1.3.6.1.4.1.5624.1.2.27.1.4.1.2 | InetAddressType | read-create | The type of Internet address by which the
RADIUS Accounting server is reachable. |
| IP etsysRadiusAcctClientServerAddress | 1.3.6.1.4.1.5624.1.2.27.1.4.1.3 | InetAddress | read-create | The Internet address for the RADIUS Accounting
server. Note that implementations must limit
themselves to a single entry in this table per
reachable server.
The etsysRadiusAcctClientServerAddress may not be
empty due to the SIZE restriction. Also the size
of a DNS name is limited to 64 characters.
This parameter value is maintained across system
reboots. |
| I32 etsysRadiusAcctClientServerPortNumber | 1.3.6.1.4.1.5624.1.2.27.1.4.1.4 | Integer32 | read-create | The UDP port number (1-65535) the client is using
to send requests to this server. The officially
assigned port number for RADIUS Accounting is 1813.
This parameter value is maintained across system
reboots. |
| OCT etsysRadiusAcctClientServerSecret | 1.3.6.1.4.1.5624.1.2.27.1.4.1.5 | OCTET STRING | read-create | This object is the secret shared between the RADIUS
Accounting server and RADIUS client. This
parameter value is maintained across system reboots.
While the 'official' MAX-ACCESS for this object is
read-create, all security-conscious implementations
will 'lie' on a read, and return a null-string, or
something else that is fairly innocuous. The
ability to read back passwords and secret
encryption keys is generally a Bad Thing (tm). |
| T/F etsysRadiusAcctClientServerSecretEntered | 1.3.6.1.4.1.5624.1.2.27.1.4.1.6 | TruthValue | read-only | This indicates the existence of a shared secret. |
| I32 etsysRadiusAcctClientServerRetryTimeout | 1.3.6.1.4.1.5624.1.2.27.1.4.1.7 | Integer32 | read-create | The number of seconds to wait for a RADIUS Accounting
Server to respond to a request. This parameter value
is maintained across system reboots. |
| I32 etsysRadiusAcctClientServerRetries | 1.3.6.1.4.1.5624.1.2.27.1.4.1.8 | Integer32 | read-create | The number of times to resend an accounting packet
if a RADIUS Accounting Server does not respond to a
request. This parameter value is maintained across
system reboots. |
| I32 etsysRadiusAcctClientServerClearTime | 1.3.6.1.4.1.5624.1.2.27.1.4.1.9 | Integer32 | read-create | On a read, this value indicates the number of seconds
since the counters, as defined in the IETF standard
RADIUS Accounting Client MIB (RFC2618), were cleared.
On a write, the client counters will be cleared and
the clear time will be set to zero. |
| ROW etsysRadiusAcctClientServerStatus | 1.3.6.1.4.1.5624.1.2.27.1.4.1.10 | RowStatus | read-create | Lets users create and delete RADIUS Accounting
server entries on systems that support this
capability.
Rules
1. When creating a RADIUS Accounting Client, it
is up to the management station to determine a
suitable etsysRadiusAcctClientServerIndex.
To facilitate interoperability, agents should not
put any restrictions on the
etsysRadiusAcctClientServerIndex beyond the
obvious ones that it be valid and unused.
2. Before a new row can become 'active', values
must be supplied for the columnar objects
etsysRadiusAcctClientClientServerAddress,
and etsysRadiusAcctClientServerSecret.
3. The value of etsysRadiusAcctClientServerStatus
must be set to 'notInService' in order to modify
a writable object in the same conceptual row.
4. etsysRadiusAcctClientServer entries whose
status is 'notReady' or 'notInService' will
not be used for Accounting. |
| I32 etsysRadiusAcctClientServerUpdateInterval | 1.3.6.1.4.1.5624.1.2.27.1.4.1.11 | Integer32 | read-create | This indicates how many seconds elapse between accounting
interim updates from the client to this RADIUS server. This
parameter value is maintained across system reboots.
A value of zero means no Interim Updates. If the value
is less than etsysRadiusAcctClientServerIntervalMinimum, the
etsysRadiusAcctClientServerIntervalMinimum value will be used
for the update interval time. If RADIUS Accounting is not
enabled, this object is ignored. Note that Accounting
Interim Updates are not issued by the RADIUS Accounting
Client, unless so requested by the RADIUS Server in an Access
Accept packet.
A value of -1 indicates that this object is not
configured and this device will use the value
configured in etsysRadiusAcctClientUpdateInterval
for the minimum value in seconds between accounting
interim updates for this RADIUS server. |
| I32 etsysRadiusAcctClientServerIntervalMinimum | 1.3.6.1.4.1.5624.1.2.27.1.4.1.12 | Integer32 | read-create | This indicates the minimum value in seconds between
accounting interim updates supported by the managed
entity for this RADIUS server. This parameter value
is maintained across system reboots. If RADIUS
Accounting is not enabled, this object is ignored.
A value of -1 indicates that this object is not
configured and this device will use the value
configured in etsysRadiusAcctClientIntervalMinimum
for the minimum value in seconds between accounting
interim updates for this RADIUS server. |
| etsysRadiusAcctClientMIBConformance | 1.3.6.1.4.1.5624.1.2.27.2 | | | |
| etsysRadiusAcctClientMIBCompliances | 1.3.6.1.4.1.5624.1.2.27.2.1 | | | |
| etsysRadiusAcctClientMIBCompliance | 1.3.6.1.4.1.5624.1.2.27.2.1.2 | | | The compliance statement for Accounting clients
implementing the RADIUS Accounting Client MIB. |
| etsysRadiusAcctClientMIBComplianceV2 | 1.3.6.1.4.1.5624.1.2.27.2.1.3 | | | The compliance statement for Accounting clients
implementing the RADIUS Accounting Client MIB. |
| etsysRadiusAcctClientMIBComplianceV3 | 1.3.6.1.4.1.5624.1.2.27.2.1.4 | | | The compliance statement for Accounting clients
implementing the RADIUS Accounting Client MIB. |
| etsysRadiusAcctClientMIBGroups | 1.3.6.1.4.1.5624.1.2.27.2.2 | | | |
| etsysRadiusAcctClientMIBGroup | 1.3.6.1.4.1.5624.1.2.27.2.2.1 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
This MIB provides read-write access to configuration
objects not provided in the standard RADIUS Accounting Client
MIB (RFC2618). However, the write capability must only
be supported for SNMPv3, or other SNMP versions with
adequately strong security. |
| etsysRadiusAcctClientMIBGroupV2 | 1.3.6.1.4.1.5624.1.2.27.2.2.2 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
etsysRadiusAcctClientServerClearTime was deprecated in
this group. |
| etsysRadiusAcctClientMIBGroupV3 | 1.3.6.1.4.1.5624.1.2.27.2.2.3 | | | The basic collection of objects providing a proprietary
extension to the standard RADIUS Client MIB.
etsysRadiusAcctClientServerClearTime was deprecated in
this group. |