| OID symbolic | OID numeric | Type | Access | Description |
| jnxVplsGenericDraft01MIB | 1.3.6.1.4.1.2636.5.8 | | | Copyright (C) The IETF Trust (2010). The initial
version of this MIB module was published in RFC XXXX.
-- RFC Editor: Please replace XXXX with RFC number & remove
-- this note.
For full legal notices see the RFC itself or see:
http://www.ietf.org/copyrights/ianamib.html
This MIB module contains generic managed object definitions
for Virtual Private LAN Services as in [RFC4762] and
[RFC4761]
This MIB module enables the use of any underlying PseudoWire
network. |
| jnxVplsNotifications | 1.3.6.1.4.1.2636.5.8.0 | | | |
| NTF jnxVplsStatusChanged | 1.3.6.1.4.1.2636.5.8.0.1 | | | The jnxVplsStatusChanged notification is generated
when there is a change in the administrative or
operating status of a VPLS service. |
| NTF jnxVplsFwdFullAlarmRaised | 1.3.6.1.4.1.2636.5.8.0.2 | | | The jnxVplsFwdFullAlarmRaised notification is
generated when the utilization of the Forwarding
database is above the value specified by
jnxVplsConfigFwdFullHighWatermark. |
| NTF jnxVplsFwdFullAlarmCleared | 1.3.6.1.4.1.2636.5.8.0.3 | | | The jnxVplsFwdFullAlarmCleared notification is
generated when the utilization of the Forwarding
database is below the value specified by
jnxVplsConfigFwdFullLowWatermark. |
| jnxVplsObjects | 1.3.6.1.4.1.2636.5.8.1 | | | |
| U32 jnxVplsConfigIndexNext | 1.3.6.1.4.1.2636.5.8.1.1 | Unsigned32 | read-only | This object contains an appropriate value to be used
for jnxVplsConfigIndex when creating entries in the
jnxVplsConfigTable. The value 0 indicates that no
unassigned entries are available. To obtain the
value of jnxVplsConfigIndex for a new entry in the
jnxVplsConfigTable, the manager issues a management
protocol retrieval operation to obtain the current
value of jnxVplsConfigIndex. After each retrieval
operation, the agent should modify the value to
reflect the next unassigned index. After a manager
retrieves a value the agent will determine through
its local policy when this index value will be made
available for reuse. |
| jnxVplsConfigTable | 1.3.6.1.4.1.2636.5.8.1.2 | | not-accessible | This table specifies information for configuring
and monitoring Virtual Private Lan Services(VPLS). |
| jnxVplsConfigEntry | 1.3.6.1.4.1.2636.5.8.1.2.1 | | not-accessible | A row in this table represents a Virtual Private Lan
Service(VPLS) in a packet network. It is indexed by
jnxVplsConfigIndex, which uniquely identifies a single VPLS.
A row is created by the operator or by the agent if a
VPLS service is created by non-SNMP application or
due to autodiscovery process.
None of the read-create objects values can be
changed when jnxVplsConfigRowStatus is in the active(1)
state. Changes are allowed when the jnxVplsConfigRowStatus
is in notInService(2) or notReady(3) states only.
If the operator need to change one of the values
for an active row the jnxVplsConfigRowStatus should be
first changed to notInService(2), the objects may
be changed now, and later to active(1) in order to
re-initiate the signaling process with the new
values in effect. |
| U32 jnxVplsConfigIndex | 1.3.6.1.4.1.2636.5.8.1.2.1.1 | Unsigned32 | read-only | Unique index for the conceptual row identifying
a VPLS service. |
| STR jnxVplsConfigName | 1.3.6.1.4.1.2636.5.8.1.2.1.2 | SnmpAdminString | read-only | A textual name of the VPLS.
If there is no local name, or this object is
otherwise not applicable, then this object MUST
contain a zero-length octet string. |
| STR jnxVplsConfigDescr | 1.3.6.1.4.1.2636.5.8.1.2.1.3 | SnmpAdminString | read-only | A textual string containing information about the
VPLS service. If there is no information for this VPLS
service, then this object MUST contain a zero-length
octet string. |
| INT jnxVplsConfigAdminStatus | 1.3.6.1.4.1.2636.5.8.1.2.1.4 | INTEGER | read-only | The desired administrative state of the VPLS
service. If the administrative status of the
Vpls service is changed to enable then this
service is able to utilize the pseudo wire to
perform the tasks of a VPLS service.
The testing(3) state indicates that no operational
packets can be passed. |
| T/F jnxVplsConfigMacLearning | 1.3.6.1.4.1.2636.5.8.1.2.1.6 | TruthValue | read-only | This object specifies if MAC Learning is enabled
in this service. If this object is true then Mac
Learning is enabled. If false, then Mac Learning is
disabled. |
| T/F jnxVplsConfigDiscardUnknownDest | 1.3.6.1.4.1.2636.5.8.1.2.1.7 | TruthValue | read-only | If the value of this object is 'true', then frames
received with an unknown destination MAC are discarded
in this VPLS. If 'false', then the packets are
processed. |
| T/F jnxVplsConfigMacAging | 1.3.6.1.4.1.2636.5.8.1.2.1.8 | TruthValue | read-only | If the value of this object is 'true'
then the MAC ageing process is enabled in
this VPLS. If 'false', then the MAC ageing process
is disabled |
| U32 jnxVplsConfigFwdFullHighWatermark | 1.3.6.1.4.1.2636.5.8.1.2.1.10 | Unsigned32 | read-only | This object specifies the utilization of the
forwarding database for this VPLS instance at
which the jnxVplsFwdFullAlarmRaised notification
will be sent. |
| U32 jnxVplsConfigFwdFullLowWatermark | 1.3.6.1.4.1.2636.5.8.1.2.1.11 | Unsigned32 | read-only | This object specifies the utilization of the
forwarding database for this VPLS instance
at which the jnxVplsFwdFullAlarmCleared
notification will be sent. |
| ROW jnxVplsConfigRowStatus | 1.3.6.1.4.1.2636.5.8.1.2.1.12 | RowStatus | read-only | For creating, modifying, and deleting this row.
None of the read-create objects in the
conceptual rows may be changed when this
object is in the active(1) state. |
| U32 jnxVplsConfigMtu | 1.3.6.1.4.1.2636.5.8.1.2.1.13 | Unsigned32 | read-only | The value of this object specifies the MTU of this
vpls instance. |
| VPN jnxVplsConfigVpnId | 1.3.6.1.4.1.2636.5.8.1.2.1.14 | VPNIdOrZero | read-only | This objects indicates the IEEE 802-1990
VPN ID of the associated VPLS service. |
| INT jnxVplsConfigServiceType | 1.3.6.1.4.1.2636.5.8.1.2.1.15 | INTEGER | read-only | The value of this object specifies the type of
service emulated by this vpls instance. |
| STO jnxVplsConfigStorageType | 1.3.6.1.4.1.2636.5.8.1.2.1.16 | StorageType | read-only | This variable indicates the storage type for this row. |
| jnxVplsStatusTable | 1.3.6.1.4.1.2636.5.8.1.3 | | not-accessible | This table provides information for monitoring
Virtual Private Lan Services(VPLS). |
| jnxVplsStatusEntry | 1.3.6.1.4.1.2636.5.8.1.3.1 | | not-accessible | A row in this table represents a Virtual Private Lan
Service(VPLS) in a packet network. It is indexed by
jnxVplsConfigIndex, which uniquely identifies a single VPLS.
A row in this table is automatically created by the agent
when a VPLS service is configured. |
| INT jnxVplsStatusOperStatus | 1.3.6.1.4.1.2636.5.8.1.3.1.1 | INTEGER | read-only | The current operational state of this VPLS Service. |
| C32 jnxVplsStatusPeerCountEx | 1.3.6.1.4.1.2636.5.8.1.3.1.2 | Counter32 | read-only | This objects specifies the number of peers
present in this vpls instance. |
| jnxVplsPwBindTable | 1.3.6.1.4.1.2636.5.8.1.4 | | not-accessible | This table provides an association between a
VPLS service and the corresponding Pseudo
Wires. A service can have more than one Pseudo
Wire association. Pseudo Wires are defined in
the pwTable |
| jnxVplsPwBindEntry | 1.3.6.1.4.1.2636.5.8.1.4.1 | | not-accessible | Each row represents an association between a
VPLS instance and one or more Pseudo Wires
defined in the pwTable. Each index is unique
in describing an entry in this table. However
both indexes are required to define the one
to many association of service to
pseudowire. |
| INT jnxVplsPwBindConfigType | 1.3.6.1.4.1.2636.5.8.1.4.1.1 | INTEGER | read-only | The value of this object indicates
whether the Pseudo Wire binding was created
manually or via autodiscovery.
The value of this object must be
specifed when the row is created and cannot
be changed while the row status is active(1) |
| INT jnxVplsPwBindType | 1.3.6.1.4.1.2636.5.8.1.4.1.2 | INTEGER | read-only | The value of this object indicates
whether the Pseudo Wire binding is of
type mesh or spoke.
The value of this object must be
specifed when the row is created and cannot
be changed while the row status is active(1) |
| ROW jnxVplsPwBindRowStatus | 1.3.6.1.4.1.2636.5.8.1.4.1.3 | RowStatus | read-only | For creating, modifying, and deleting this row.
None of the read-create objects in the
conceptual rows may be changed when this
object is in the active(1) state |
| STO jnxVplsPwBindStorageType | 1.3.6.1.4.1.2636.5.8.1.4.1.4 | StorageType | read-only | This variable indicates the storage type for this row. |
| PWI jnxVplsPwBindIndex | 1.3.6.1.4.1.2636.5.8.1.4.1.5 | PwIndexType | read-only | Secondary Index for the conceptual row identifying
a pseudowire within the PwEntry which MUST
match an entry from the PW-STD-MIB's PwTable
which represents an already-provisioned
pseudowire that is then associated with this
VPLS instance. |
| jnxVplsBgpADConfigTable | 1.3.6.1.4.1.2636.5.8.1.5 | | not-accessible | This table specifies information for configuring
BGP Auto-discovery parameters for a given Vpls service. |
| jnxVplsBgpADConfigEntry | 1.3.6.1.4.1.2636.5.8.1.5.1 | | not-accessible | A row in this table represents BGP based autodiscovery
is in use for this instance of Vpls.
A row in this table is indexed by jnxVplsConfigIndex, which
uniquely identifies a single VPLS.
None of the read-create objects can be changed when
jnxVplsBGPADConfigRowStatus is in active(1) state. Changes
are allowed when the jnxVplsBGPADConfigRowStatus is in
notInService(2) or notReady(3) states only.
If the operator need to change one of the values
for an active row the jnxVplsConfigRowStatus should be
first changed to notInService(2), the objects may
be changed now, and later to active(1) in order to
re-initiate the signaling process with the new
values in effect. |
| JNX jnxVplsBgpADConfigRouteDistinguisher | 1.3.6.1.4.1.2636.5.8.1.5.1.1 | JnxVplsBgpRouteDistinguisher | read-only | The route distinguisher for this VPLS. See [RFC4364]
for a complete definition of a route distinguisher.
for more details on use of a route distinguisher
for a VPLS service, see [RFC4761] |
| U32 jnxVplsBgpADConfigPrefix | 1.3.6.1.4.1.2636.5.8.1.5.1.2 | Unsigned32 | read-only | In case of auto-discovery the default prefix advertised
is the ip address of the loopback. In case the user wants
to override the loopback address, jnxVplsBgpADConfigPrefix
should be set. When this value if non-zero it is used
as the advertised IP address in the NLRI. |
| JNX jnxVplsBgpADConfigVplsId | 1.3.6.1.4.1.2636.5.8.1.5.1.3 | JnxVplsBgpRouteDistinguisher | read-only | VplsId is a unique identifier for all VSIs belonging to
the same VPLS. It is advertised as an extended community |
| ROW jnxVplsBgpADConfigRowStatus | 1.3.6.1.4.1.2636.5.8.1.5.1.4 | RowStatus | read-only | For creating, modifying, and deleting this row.
None of the read-create objects in the
conceptual rows may be changed when this
object is in the active(1) state. |
| jnxVplsBgpRteTargetTable | 1.3.6.1.4.1.2636.5.8.1.6 | | not-accessible | This table specifies the list of Route Targets
imported or exported by BGP during auto-discovery of VPLS. |
| jnxVplsBgpRteTargetEntry | 1.3.6.1.4.1.2636.5.8.1.6.1 | | not-accessible | An entry in this table specifies the value of the
Route Target being used by BGP. Depending on the value
of jnxVplsBgpRteTargetType an RT might be exported or
imported or both. Every VPLS which
uses auto-discovery for finding peer nodes can import and
export multiple Route Targets. This representation allows
support for hierarchical VPLS. |
| U32 jnxVplsBgpRteTargetIndex | 1.3.6.1.4.1.2636.5.8.1.6.1.1 | Unsigned32 | not-accessible | This index along with jnxVplsConfigIndex,identifies one entry
in the jnxVplsBgpRteTargetTable. By keeping jnxVplsConfigIndex
constant and using new value of jnxVplsBgpRteTargetIndex user
can configure multiple Route Targets for the same Vpls. |
| JNX jnxVplsBgpRteTargetRTType | 1.3.6.1.4.1.2636.5.8.1.6.1.2 | JnxVplsBgpRouteTargetType | read-only | Used to define the type of a route target usage.
Route targets can be specified to be imported,
exported, or both. For a complete definition of a
route target, see [RFC4364]. |
| JNX jnxVplsBgpRteTargetRT | 1.3.6.1.4.1.2636.5.8.1.6.1.3 | JnxVplsBgpRouteTarget | read-only | The route target associated with the VPLS service.
For more details on use of route targets
for a VPLS service, see [RFC4761] |
| ROW jnxVplsBgpRteTargetRTRowStatus | 1.3.6.1.4.1.2636.5.8.1.6.1.4 | RowStatus | read-only | This variable is used to create, modify, and/or
delete a row in this table. When a row in this
table is in active(1) state, no objects in that row
can be modified |
| T/F jnxVplsStatusNotifEnable | 1.3.6.1.4.1.2636.5.8.1.7 | TruthValue | read-write | If this object is set to true(1), then it enables
the emission of jnxVplsStatusChanged
notification; otherwise this notification is not
emitted. |
| U32 jnxVplsNotificationMaxRate | 1.3.6.1.4.1.2636.5.8.1.8 | Unsigned32 | read-write | This object indicates the maximum number of
notifications issued per second. If events occur
more rapidly, the implementation may simply fail to
emit these notifications during that period, or may
queue them until an appropriate time. A value of 0
means no throttling is applied and events may be
notified at the rate at which they occur. |
| jnxVplsConformance | 1.3.6.1.4.1.2636.5.8.2 | | | |