--MibName=wsaObjects -- #ident "@(#)$Header: wsatrap.mib,v 12.29 2005/11/02 $ SNI" WSA-TRAP-MIB DEFINITIONS ::= BEGIN -- This MIB summarizes all traps used by PRIMEPOWER HW Monitoring -- This is a conversion of most PRIMEPOWER ServerView Suite events to SNMP-Traps -- Copyright (C) 2000-2005 by Fujitsu Siemens Computers GmbH -- -- Author: Reinhard Kockmann / Dr. Ruediger Schuster / Peter Kalthoff -- Date of Changes: 2005-10-27 -- Changes: New attributes for PRIMEPOWER ServerView Suite 2.2B10 included -- ******************************************************************* IMPORTS OBJECT-TYPE FROM RFC-1212 DisplayString FROM RFC1213-MIB enterprises FROM RFC1155-SMI; -- OID: 1.3.6.1.4.1. -- SNI Server Management MIB nodes sni OBJECT IDENTIFIER ::= { enterprises 231 } sniProductMibs OBJECT IDENTIFIER ::= { sni 2 } wsaObjects OBJECT IDENTIFIER ::= { sniProductMibs 41 } wsaInfo OBJECT IDENTIFIER ::= { wsaObjects 1 } -- OID: 1.3.6.1.4.1.231.2.41.1 wsaState OBJECT IDENTIFIER ::= { wsaObjects 2 } -- OID: 1.3.6.1.4.1.231.2.41.2 wsaTrapParams OBJECT IDENTIFIER ::= { wsaObjects 3 } -- OID: 1.3.6.1.4.1.231.2.41.3 -- in order to support testTrap sniExtensions OBJECT IDENTIFIER ::= { sniProductMibs 10 } sniServerMgmt OBJECT IDENTIFIER ::= { sniExtensions 2 } sniCommon OBJECT IDENTIFIER ::= { sniServerMgmt 2 } sniServerControl OBJECT IDENTIFIER ::= { sniCommon 5 } diagnostics OBJECT IDENTIFIER ::= { sniServerControl 13 } trapInfo OBJECT IDENTIFIER ::= { sniServerControl 20 } -- textual conventions -- a truth value Boolean ::= INTEGER { true(1), false(2) } -- readable Server Type ServerType ::= INTEGER { partition(1), console(2), standalone(3) } StateType ::= INTEGER { ok(1), error(2), defect(3), unknown(99) } ModeType ::= INTEGER { oldmode(1), newmode(2) } -- The MIB objects -- -- System information (WSA specific) -- wsaMachineType OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Model Name" ::= { wsaInfo 1 } -- OID: 1.3.6.1.4.1.231.2.41.1.1 wsaNumberOfCpu OBJECT-TYPE SYNTAX INTEGER ACCESS read-only STATUS mandatory DESCRIPTION "Number of CPUs" ::= { wsaInfo 2 } -- OID: 1.3.6.1.4.1.231.2.41.1.2 wsaMemory OBJECT-TYPE SYNTAX INTEGER ACCESS read-only STATUS mandatory DESCRIPTION "Size of Memory in Megabyte" ::= { wsaInfo 3 } -- OID: 1.3.6.1.4.1.231.2.41.1.3 wsaCpuType OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Architecture of CPU" ::= { wsaInfo 4 } -- OID: 1.3.6.1.4.1.231.2.41.1.4 wsaCpuFrequency OBJECT-TYPE SYNTAX INTEGER ACCESS read-only STATUS mandatory DESCRIPTION "Frequency of CPU" ::= { wsaInfo 5 } -- OID: 1.3.6.1.4.1.231.2.41.1.5 wsaServerUptime OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Uptime of Server System" ::= { wsaInfo 6 } -- OID: 1.3.6.1.4.1.231.2.41.1.6 wsaServerType OBJECT-TYPE SYNTAX ServerType ACCESS read-only STATUS mandatory DESCRIPTION "Returns Type of Server: Console, partition, standalone" ::= { wsaInfo 7 } -- OID 1.3.6.1.4.1.231.2.41.1.7 wsaSMCName OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "If this node is a Partition, then SMC name, empty String else" ::= {wsaInfo 8 } -- OID 1.3.6.1.4.1.231.2.41.1.8 wsaMachineName OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "If this node is a Partition, then Machine name, empty String else" ::= {wsaInfo 9 } -- OID 1.3.6.1.4.1.231.2.41.1.9 wsaIsManagementServer OBJECT-TYPE SYNTAX Boolean ACCESS read-only STATUS mandatory DESCRIPTION "If this node is used by WSA as a Management Server: true, else false" ::= {wsaInfo 10 } -- OID 1.3.6.1.4.1.231.2.41.1.10 wsaAgentVersion OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Version string of the wsaagt: n.nAnn nn" ::= {wsaInfo 11 } -- OID 1.3.6.1.4.1.231.2.41.1.11 wsaAgentMode OBJECT-TYPE SYNTAX ModeType ACCESS read-only STATUS mandatory DESCRIPTION "Mode of Agent: 1: oldmode, 2: newmode" ::= { wsaInfo 12 } -- OID: 1.3.6.1.4.1.231.2.41.1.12 wsaHostId OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Hostid of node" ::= { wsaInfo 13 } -- OID: 1.3.6.1.4.1.231.2.41.1.13 wsaProductName OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Product name of this node (e.g. PRIMEPOWER PW450)" ::= { wsaInfo 14 } -- OID: 1.3.6.1.4.1.231.2.41.1.14 wsaOSDetails OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Details about the operating system" ::= { wsaInfo 15 } -- OID: 1.3.6.1.4.1.231.2.41.1.15 wsaManagementServer OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Contains the name of the management server for this node" ::= { wsaInfo 16 } -- OID: 1.3.6.1.4.1.231.2.41.1.16 -- -- Status information -- wsaLarStatus OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Status of LAR events: NoFlagSet : all components working properly, no failure ErrorSet : at least one component has a problem, but it can still work DefectSet : at least one component is defect - it can't work any more " ::= { wsaState 1 } -- OID: 1.3.6.1.4.1.231.2.41.2.1 -- wsaNodeStatus is legacy wsaNodeStatus OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Node is in the cluster or not" ::= { wsaState 2 } -- OID: 1.3.6.1.4.1.231.2.41.2.2 wsaRunning OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "WSA is running/not running" ::= { wsaState 3 } -- OID: 1.3.6.1.4.1.231.2.41.2.3 -- New state variables start here wsaHwStateEnvironment OBJECT-TYPE SYNTAX StateType ACCESS read-only STATUS mandatory DESCRIPTION "Indicates if Defect, Error or OK for power supplies and FANs" ::= { wsaState 4 } -- OID: 1.3.6.1.4.1.231.2.41.2.4 wsaHwStateController OBJECT-TYPE SYNTAX StateType ACCESS read-only STATUS mandatory DESCRIPTION "Indicates if Defect, Error or OK for controllers, cpu and memory dimms" ::= { wsaState 5 } -- OID: 1.3.6.1.4.1.231.2.41.2.5 wsaHwStateStorage OBJECT-TYPE SYNTAX StateType ACCESS read-only STATUS mandatory DESCRIPTION "Indicates if a disk or tape device is defect" ::= { wsaState 6 } -- OID: 1.3.6.1.4.1.231.2.41.2.6 wsaHwStateGlobal OBJECT-TYPE SYNTAX StateType ACCESS read-only STATUS mandatory DESCRIPTION "Indicates if a hardware component is defect" ::= { wsaState 7 } -- OID: 1.3.6.1.4.1.231.2.41.2.7 -- -- Trap parameters -- wsaServerName OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 1 } -- OID: 1.3.6.1.4.1.231.2.41.3.1 wsaTrapTime OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 2 } -- OID: 1.3.6.1.4.1.231.2.41.3.2 wsaLarComment OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Comment item provided by internal HW monitoring (LAR)" ::= { wsaTrapParams 3 } -- OID: 1.3.6.1.4.1.231.2.41.3.3 wsaHWConfAddr OBJECT-TYPE SYNTAX DisplayString ACCESS read-only STATUS mandatory DESCRIPTION "Internal unique HW address of the component" ::= { wsaTrapParams 4 } -- OID: 1.3.6.1.4.1.231.2.41.3.4 wsaModule OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 5 } -- OID: 1.3.6.1.4.1.231.2.41.3.5 wsaSeverity OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Contains the severity of the related log messages (INFO, NOTICE, ...)" ::= { wsaTrapParams 6 } -- OID: 1.3.6.1.4.1.231.2.41.3.6 wsaHwMessage OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Contains the driver message for HW events" ::= { wsaTrapParams 7 } -- OID: 1.3.6.1.4.1.231.2.41.3.7 wsaEventType OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 8 } -- OID: 1.3.6.1.4.1.231.2.41.3.8 wsaHw OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 9 } -- OID: 1.3.6.1.4.1.231.2.41.3.9 wsaHwState OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 10 } -- OID: 1.3.6.1.4.1.231.2.41.3.10 wsaRaidDriver OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 11 } -- OID: 1.3.6.1.4.1.231.2.41.3.11 wsaFileMonComment OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 12 } -- OID: 1.3.6.1.4.1.231.2.41.3.12 wsaFileMonValue OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 13 } -- OID: 1.3.6.1.4.1.231.2.41.3.13 wsaRuleName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 14 } -- OID: 1.3.6.1.4.1.231.2.41.3.14 wsaResourceName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 15 } -- OID: 1.3.6.1.4.1.231.2.41.3.15 wsaPerfValue OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 16 } -- OID: 1.3.6.1.4.1.231.2.41.3.16 wsaRuleSetName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "" ::= { wsaTrapParams 17 } -- OID: 1.3.6.1.4.1.231.2.41.3.17 -- LAR-Format in file hwerrors -- TheLAR-Format describes the error, defect, activation or deactivation of -- HW components. -- :::
::::