PSA-WinMpdTrap-MIB DEFINITIONS ::= BEGIN --PRIMEQUEST system management MIB for Partition -- -- --$Copyright$ --Copyright Fujitsu Limited 2009 --All rights reserved -- -- --MIB Revision: 02000003 -- IMPORTS OBJECT-TYPE FROM RFC-1212 TRAP-TYPE FROM RFC-1215 mib-2, DisplayString FROM RFC1213-MIB TimeTicks, Counter, Gauge, IpAddress, mgmt, enterprises FROM RFC1155-SMI; --enterprises OBJECT IDENTIFIER ::={ iso org(3) dod(6) internet(1) private(4) 1 } -- --PRIMEQUEST system management MIB nodes --fujitsu: 1.3.6.1.4.1.211 -- products: 1.3.6.1.4.1.211.1 -- iaServer: 1.3.6.1.4.1.211.1.31 -- primequest: 1.3.6.1.4.1.211.1.31.1 -- partition: 1.3.6.1.4.1.211.1.31.1.2 -- --Trap enterprise is "psaWinMpdTrap" --FUJITSU PRIMEQUEST system management MIB nodes for Partition fujitsu OBJECT IDENTIFIER ::={ enterprises 211 } products OBJECT IDENTIFIER ::={ fujitsu 1 } iaServer OBJECT IDENTIFIER ::={ products 31 } primequest OBJECT IDENTIFIER ::={ iaServer 1 } partition OBJECT IDENTIFIER ::={ primequest 2 } parititonVariables OBJECT IDENTIFIER ::={ partition 200 } partitionEnterprise OBJECT IDENTIFIER ::={ partition 201 } psaComTrap OBJECT IDENTIFIER ::={ partitionEnterprise 1 } psaWinIntelE100Trap OBJECT IDENTIFIER ::={ partitionEnterprise 51 } psaWinIntelE1000Trap OBJECT IDENTIFIER ::={ partitionEnterprise 52 } psaWinBcm5700Trap OBJECT IDENTIFIER ::={ partitionEnterprise 53 } psaWinEmulexTrap OBJECT IDENTIFIER ::={ partitionEnterprise 54 } psaWinLsiLogicTrap OBJECT IDENTIFIER ::={ partitionEnterprise 55 } psaWinDiskTrap OBJECT IDENTIFIER ::={ partitionEnterprise 56 } psaWinGrmpdTrap OBJECT IDENTIFIER ::={ partitionEnterprise 57 } psaWinDiskMirrorTrap OBJECT IDENTIFIER ::={ partitionEnterprise 58 } psaWinXframe2Trap OBJECT IDENTIFIER ::={ partitionEnterprise 59 } psaWinIntelE1000expTrap OBJECT IDENTIFIER ::={ partitionEnterprise 60 } psaWinSvsRaidTrap OBJECT IDENTIFIER ::={ partitionEnterprise 61 } psaWinMpdTrap OBJECT IDENTIFIER ::={ partitionEnterprise 62 } psaWinGlsTrap OBJECT IDENTIFIER ::={ partitionEnterprise 63 } --*************************************************************************************** -- --FUJITSU PRIMEQUEST system management trap parameter variables for Partition -- They aren't directly accessibles(can't use snmp get/set command), but sent with trap -- --*************************************************************************************** trapVarComInfo OBJECT IDENTIFIER ::={ parititonVariables 1 } trapPartitionName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Partition name which trap is generated." ::= { trapVarComInfo 1 } trapPartitionId OBJECT-TYPE SYNTAX INTEGER ACCESS not-accessible STATUS mandatory DESCRIPTION "Paritition identifier which trap is generated." ::= { trapVarComInfo 2 } trapEventLevel OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Event level" ::= { trapVarComInfo 3 } trapEventId OBJECT-TYPE SYNTAX INTEGER ACCESS not-accessible STATUS mandatory DESCRIPTION "Event Identifier" ::= { trapVarComInfo 4 } trapUnitName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Unit name which trap is generated." ::= { trapVarComInfo 5 } trapMmbVip OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Management board vertual IP address." ::= { trapVarComInfo 6 } trapVarDivInfo OBJECT IDENTIFIER ::={ parititonVariables 2 } trapPartNo OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Parts number of trap source." ::= { trapVarDivInfo 1 } trapStepping OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 2 } trapSerialNo OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Serial number of trap source. " ::= { trapVarDivInfo 3 } trapModelNo OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Model number of trap source." ::= { trapVarDivInfo 4 } trapSuspect OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Logical name or pci bus number of trap source." ::= { trapVarDivInfo 5 } trapVendorId OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Vendor identifier of trap source." ::= { trapVarDivInfo 6 } trapDeviceId OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Device identifier of trap source." ::= { trapVarDivInfo 7 } trapRevision OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Revision of trap source." ::= { trapVarDivInfo 8 } trapCardName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Device name of trap source." ::= { trapVarDivInfo 9 } trapErrDetail OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 10 } trapErrCode OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 11 } trapIrpCode OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 12 } trapHbaNo OBJECT-TYPE SYNTAX INTEGER ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 13 } trapErrCause OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 14 } trapPathNo OBJECT-TYPE SYNTAX INTEGER ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 15 } trapDiskId OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 16 } trapFmrDiskId OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 17 } trapCurDiskId OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 18 } trapPathId OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 19 } trapPhysIf OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 20 } trapVirtualIf OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 21 } trapLogicalIp OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 22 } trapWatchIp OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 23 } trapInterface OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 24 } trapSourceIp OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 25 } trapDestIp OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION " " ::= { trapVarDivInfo 26 } trapModelName OBJECT-TYPE SYNTAX DisplayString ACCESS not-accessible STATUS mandatory DESCRIPTION "Model name of trap source." ::= { trapVarDivInfo 27 } --*************************************************************************************** -- --FUJITSU PRIMEQUEST system management TRAP definition for Partition -- Trap enterprise: psaWinMpdTrap (.1.3.6.1.4.1.211.1.31.1.2.201.62) -- --*************************************************************************************** mpdWinEvent0 TRAP-TYPE ENTERPRISE psaWinMpdTrap VARIABLES { trapPartitionName, trapPartitionId, trapEventLevel, trapEventId, trapUnitName, trapMmbVip } DESCRIPTION "MPD: Adapter or Device or FC-Network error (MPD detected event)" --#TYPE "Mpd Win Event 0" --#SUMMARY "%s(PID=%d) %s %d %s MPD: Adapter or Device or FC-Network error (MPD detected event)" --#ARGUMENTS { 0, 1, 2, 3, 4 } --#SEVERITY MINOR ::= 25000 mpdWinEvent1 TRAP-TYPE ENTERPRISE psaWinMpdTrap VARIABLES { trapPartitionName, trapPartitionId, trapEventLevel, trapEventId, trapUnitName, trapSuspect, trapVendorId, trapDeviceId, trapRevision, trapMmbVip } DESCRIPTION "MPD: Adapter or FC-Network error (An input/output error has occurred)" --#TYPE "Mpd Win Event 1" --#SUMMARY "%s(PID=%d) %s %d %s MPD:\Device\ScsiPort%s Adapter or FC-Network error (An input/output error has occurred) vendor-id=%s device-id=%s revision=%s" --#ARGUMENTS { 0, 1, 2, 3, 4, 5, 6, 7, 8 } --#SEVERITY MAJOR ::= 25001 mpdWinEvent2 TRAP-TYPE ENTERPRISE psaWinMpdTrap VARIABLES { trapPartitionName, trapPartitionId, trapEventLevel, trapEventId, trapUnitName, trapSuspect, trapVendorId, trapDeviceId, trapRevision, trapMmbVip } DESCRIPTION "MPD: Adapter or FC-Network error (An input/output error has occurred)" --#TYPE "Mpd Win Event 2" --#SUMMARY "%s(PID=%d) %s %d %s MPD:\Device\ScsiPort%s Adapter or FC-Network error (An input/output error has occurred) vendor-id=%s device-id=%s revision=%s" --#ARGUMENTS { 0, 1, 2, 3, 4, 5, 6, 7, 8 } --#SEVERITY MAJOR ::= 25002 mpdWinEvent3 TRAP-TYPE ENTERPRISE psaWinMpdTrap VARIABLES { trapPartitionName, trapPartitionId, trapEventLevel, trapEventId, trapUnitName, trapSuspect, trapVendorId, trapDeviceId, trapRevision, trapMmbVip } DESCRIPTION "MPD: Adapter or FC-Network error (Some of the paths could not be detected)" --#TYPE "Mpd Win Event 3" --#SUMMARY "%s(PID=%d) %s %d %s MPD:\Device\ScsiPort%s Adapter or FC-Network error (Some of the paths could not be detected) vendor-id=%s device-id=%s revision=%s" --#ARGUMENTS { 0, 1, 2, 3, 4, 5, 6, 7, 8 } --#SEVERITY MAJOR ::= 25003 mpdWinEvent4 TRAP-TYPE ENTERPRISE psaWinMpdTrap VARIABLES { trapPartitionName, trapPartitionId, trapEventLevel, trapEventId, trapUnitName, trapSuspect, trapVendorId, trapDeviceId, trapRevision, trapMmbVip } DESCRIPTION "MPD: Adapter or FC-Network error (device was removed)" --#TYPE "Mpd Win Event 4" --#SUMMARY "%s(PID=%d) %s %d %s MPD:\Device\ScsiPort%s Adapter or FC-Network error (device was removed) vendor-id=%s device-id=%s revision=%s" --#ARGUMENTS { 0, 1, 2, 3, 4, 5, 6, 7, 8 } --#SEVERITY MAJOR ::= 25004 mpdWinEvent5 TRAP-TYPE ENTERPRISE psaWinMpdTrap VARIABLES { trapPartitionName, trapPartitionId, trapEventLevel, trapEventId, trapUnitName, trapSuspect, trapVendorId, trapDeviceId, trapRevision, trapMmbVip } DESCRIPTION "MPD: Adapter or FC-Network error (An input/output fault)" --#TYPE "Mpd Win Event 5" --#SUMMARY "%s(PID=%d) %s %d %s MPD:\Device\ScsiPort%s Adapter or FC-Network error (An input/output fault) vendor-id=%s device-id=%s revision=%s" --#ARGUMENTS { 0, 1, 2, 3, 4, 5, 6, 7, 8 } --#SEVERITY MAJOR ::= 25005 END